
Learning Blender 2.5
Blender Download: http://www.blender.org/download/get-blender/
more info at http://pixelsix.net/workshops 

User Preferences (for Laptop users)

To change the User Preferences go to File > User Preferences 
Here you can change all kind of preferences. 

Emulate Numpad

For laptop users without a Numpad they can turn on emulate Numpad, then the normal 
keyboard numbers work as Numpad:
Tap Input > Emulate Numpad ON

Safe Preferences

To safe the preferences press Save As Defaults
Important: all current settings will be safed, also the window setup and all objects in the  
scene. To reset settings you can load factory settings: 
File > Load Factory Settings

Interface

Window Type

The Blender window interface is completely flexible. You can change every content of  
every window. 
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Click here to change window type

http://pixelsix.net/
http://pixelsix.net/workshops
http://www.blender.org/download/get-blender/


Resize a window

With the mouse between two windows, you can resize a window by dragging it. 

Maximize a window

Ctrl + Up-Arrow while holding the mouse over a window maximizes it
Ctrl + Up-Down minimizes the window again

Split & Join windows

Shift + dragging separates the view in a separate window 

Ω

Window headers

Every Window has a header, either on the top or bottom. The position can be changed by 
Right Mouse Click on the header

If the header content is bigger than the window you can move it with the third mouse 
button. 

3D View: Tools / Properties

The 3D View has two additional window areas: 
Tools (Key T) and Properties (Key N)
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 To split a window press on the up-right or 
button-left corner and drag it into the 
window area.

 To join two windows 
press on the up-right 
or button-left corner 
and drag it into 
another window area.

 Tools and Properties can also be 
opend by clicking on the plus 
icon in the top left or top right 
corner

http://pixelsix.net/


Navigation

Mouse

Right Mouse Button (RMB) select object
Left Mouse Button (LMB) place the 3D-Cursor

3 Button Mouse

Middle Mouse Button (MMB) turn view
Mouse Wheel (MW) zoom in and out
MMB + Shift move view

2 Button Mouse 

Turn on Emulate 3 Mouse Button in File > User Preferences > Tap Input
LMB + Alt turn view
LMB +  Alt + Ctrl zoom in an out
LMB + Alt + Shift move view

Changing The View

Numpad (or emulated Numpad)

Num 1 front view
Num 1 + Ctrl back view
Num 3 side view (right)
Num 3 + Ctrl side view (left)
Num 7 top view
Num 7 + Ctrl bottom view

Num 5 turn on/off perspective view

Num 2 turn view horizontal 
Num 4 turn view vertical 
Num 6 turn view  horizontal backwards
Num 8 turn view vertical backwards
Num 0 camera view

Layers

Objects can be organized in different layers. That can be turned on and off. 
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 Here you can activate deactivate layers. 
Press Shift to for multiple selection.

M-Key to move an selected object into 
another layer

http://pixelsix.net/


Objects

create object

Shift + A-Key to add a new object to the scene. 

The position of the 3D Cursor , defines the position of the new object.

 3D Cursor

select objects

A-KEY to select/deselect all objects
RMB select an object
Shift + RMB to selected multiple objects after each other 

B-Key Border Select Tool with LMB to select objects 
B-Key Border Select Tool with RMB to deselect objects from selection 
C-Key Circular Select Tool with LMB to select objects 
C-Key Circular Select Tool with RMB to deselect objects from selection 
ESC-Key or RMB to stop Circular Select Tool
Ctrl + LMB Lasso Select Tool 

3D Transform Manipulator 

 

. 

Transformation Key Shortcuts

G-Key to move selected objects
R-Key to rotate selected objects 
S-Key to scale selected objects 
LMB or Enter to accept transformation / RMB or ESC to cancel transformation 

Limit transformation on specific axis 
X-Key, Y-Key or Z-Key during transformation, to limit transformation to only one axis 
Shift + X-Key, Shift + Y-Key or Shift + Z-Key during transformation to 
exclude one axis 
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 Use the transform manipulator to do
 object transformations by hand

http://pixelsix.net/


Transformation steps
Ctrl during transformation to limit transformation to 1 grid unit increments
Shift + Ctrl during transformation to limit transformation to 0.1 grid unit increments  
Shift during transformation for fine transformation to very small steps

Clear transformation

ALT + G-Key to clear object translation (position) to 0,0,0 
ALT + R-Key  to clear object rotation to 0,0,0
ALT + S-Key  to clear object scale to 0,0,0

Delete object

X-KEY delete selected object

Copy object

Shift + D-Key to copy selected object (make duplicate) 
Alt + D-Key to make linked duplicate

Transform Properties

 

 

Parenting 

Ctrl + P-Key to link objects. The last selected object will be the parent.
ALT + P-Key to clear parent relation. To clear parent relation the child has to be 
selected. 

3D Cursor / Snap Tool

 LMB to place the 3D Cursor. Use different views to define the exact cursor position.
 Shift+C to clear the cursor position (x=0, y=0, z=0)
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Transformations can also sat by numbers 
 in the transform properties:

N-Key

 Shift+S to open the snap tool. Here you can snap the 
 position of the cursor or an selected object to each other. 

http://pixelsix.net/


3D View Shading

Camera

Active Camera

Num0 look through active camera
Ctrl + Num0 set selected object as camera 

Align Camera to View

Ctrl + Alt + Num0 to align camera to current view

Fly Mode

Shift + F-Key to enter Fly Mode
move the mouse  to pan the view 

mouse wheel to move the view forward/backward

LMB to confirm new position, RMB / ESC to go back to old position 

Render image / animation

  F12 to render the camera view
 F3 to save the rendered image
 F11 to show the last render image
  ESC to close render image view

Blender Project 

Safe project

Ctrl + W-Key to safe project 

Reset project

Ctrl + X-Key to reset to default scene / StartUp File (all unsaved data will be lost!)
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 To change the shading in 3D View click on 
 the shading button or press:

 Z-Key for wireframe view  
 ALT + Z-key for textured view 

 Render settings can be defined in:  
 Properties Window > Render Tap  

http://pixelsix.net/


Modelling

Edit Mode

  
 

Selection Mode

      
 

Selection Tools

The Border and Circular Select Tool can be used in Edit Mode as well:
B-Key Border Select Tool 
C-Key Circular Select Tool 

Increase / Decrease Selection

Ctrl Num+ to increase the selection of vertices, edges or faces
Ctrl Num- to decrease the selection of vertices, edges or faces

Selected linked vertices

If an object consist of more than one linked mesh, a linked mesh can be selected by  
selecting one vertices of the mesh and than press Ctrl + L
Or L-Key by by holding the mouse cursor over one vertices of 
the linked mesh.

Deleting 

X-Key to delete selected vertices, edges or faces

Filling 

F-Key to make edges or faces; you have to select at least two vertices

Fill selected
Shift + F-Key All selected vertices that are bound by edges are filled with faces.

Beauty Fill
Alt + F-Key The edges of all the selected triangular faces are switched in such a way 
that equally sized faces are formed. 
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 Switch to Edit Mode with the Mode Selector or:
TAP to switch between Edit Mode and Object 
Mode of an selected object

 Click on Vertice, Edge or Face Select Mode to chose 
 your selection kind or:

Ctrl + TAP to change Select Mode

  to limit selection on only visible vertices, edges or 
 faces

http://pixelsix.net/


Extrusion

E-KEY for Extrusion (X-Key, Y-Key or Z-Key you can limit the extrusion on one axis)
LMB to accept extrusion, RMB to cancel extrusion

Inner Extrusion

For inner extrusion you extrude the face (button or E-KEY ), but cancel the translation of 
the face with ESC or RMB and scale (S-Key) the face smaller. 

 

Special Editing Menu

W-Key to open the Special Edit Menu for functions like: Subdivide, Merge, Remove 
Doubles, Hide, Reveal, Select Inverse, Flip Normals, Smooth, etc.

Vertex Specials Menu

Ctrl + V-Key to open Vertex Specials for functions like: Merge, Rip, Split, Smooth 
Vertices, Hooks etc.

Edge Specials Menu

Ctrl + E-Key to open Edge Specials for functions like: Mark Seam, Mark Sharp, Edge  
Slide, Edge Loop, etc.

Face Specials Menu

Ctrl + F-Key to open Face Specials for functions like: Flip Normals, Fill etc.

Mirror Tools

Ctrl + M-Key to open Mirror tools
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 You can extrude a complete  
 region (multiple faces) or 
 individual faces

http://pixelsix.net/


Merge Tools

ALT + M-Key to open Merge tools

Loop Cut 

 This is the workflow for new loopcut tool:
• Enter Selection Preview Mode by holding the mouse 

over a mesh edge and pressing Ctrl-R.
• To choose the number of cuts, use keypad +/-, 

the mouse scroll wheel, or simply type a 
number.

• Click LMB to make the cuts.
• If you only made a single cut, you can slide the new 

edgeloop in Edgeslide mode, clicking LMB again to 
confirm the final position. 

Knife Tool

Knife Cut Exact Tool 
First select the edges you want to cut, than press K-Key and LMB to drag the mouse over 
the edges you want to cut. The edges will be cut at the exact position of the mouse.

Knife Cut Midpoint Tool 
First select the edges you want to cut, than press Shift + K-Key and LMB to drag the 
mouse over the edges you want to cut. The edges will be cut at the midpoint of the edge.

Proportional Editing-Tool

O-Key to toggle the Proportional Edit-Tool on or off 

 or select it in the menu bar, where you can also define the falloff
 
MouseWheel or Alt + Num+ / Alt + Num- the radius of the falloff can be  
 changed
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http://pixelsix.net/


Object origin 

object centre (Blender < 2.5) or pivot point (3DsMax)

set origin

Shift + Ctrl + Alt + C-Key or Origin button to open Set Origin Menu:  
Geometry to Origin, Origin to Geometry or Origin to 3D Cursor

Joining / Separating objects

Joining Objects

Ctrl + J-Key to join selected objects to one object

Separate Objects

P-Key in Edit Mode to separate selected mesh from object
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 The object origin is markt by the orange 
 point in the object. It defi nes the position, 
 rotation and scale of the object.

 The origin can be place in or outside of the 
 object mesh.

http://pixelsix.net/


Materials

Materials and textures define the surface (colour, reflection, texture...) of an object.  
Several materials and textures can be combined and applied to one object. 

Add A Material

To add a material to an object, select the object and open the Material-Tab in the 
Properties Window. 

Add multiple Materials

To add multiple materials to one object, you do the following:
1. go into Edit-Mode and select the faces the new material should be applied to
2. in the Material-Tab press on the plus sign 'Add new material slot'
3. press on 'New' to add a new material in the new material slot and change the 

diffuse colour (for testing)
4. press the 'Assign' button to assign the new material to the selected faces.    

Important parameters

 Diffuse defines the base colour of the material  
Intensity the amount of diffuse reflection 
Shader in the drop-down different diffuse shaders can
be selected (Lambert, Toon, Fresnel,...)
Ramp to set a colour gradient

 Specular defines the specular reflection (light reflection)  
 of the material 
 Intensity the amount of specular reflection 

Hardness defines how hard (sharp) the reflection is
Shader in the drop-down different specular shaders can
be selected
Ramp to set a colour gradient of the specular reflection

Transparency 
If the Transparency is checked the material can be set transparent by reducing the Alpha 
value.

Z Transparency is simple but fast method to simulate transparency
Raytrace is a more physical correct (slow) method 
Here the IOR (index of refraction) can be set, how light brakes by passing through 
the material. An explanation about IOR and a list of refraction indicies can be found 
here: http://en.wikipedia.org/wiki/Refractive_index (Water: 1.3333, Glas: 1.52)
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 Press 'Add New' to assign a 
 new material to the object.

http://pixelsix.net/
http://en.wikipedia.org/wiki/Refractive_index


Animation 
Simple animation workflow:

1. Make the Timeline visible in your screen layout (or choose the Animation Screen 
Layout) and set the length of your animation at End:

2. Select the object, you want to animate

3. Set the Current Frame to the start frame of your 
animation

4. Press I-Key (insert keyframe) to set a keyframe 
and choose the specific KeySet you want to 
animate (Location, Rotation, Scale...) 

5. Now after the first keyframe is set, change the 
Current Frame to a new position

6. Change the state of your object (Location, Rotation, 
Scale...)

7. Press I-Key again to set another keyframe

8. continue with the last three steps... 

Afterwards the animation curves can be tweaked in the Graph Editor.

TIP: Almost every parameter in Blender can be animated. Try to hold your mouse coursor  
above a parameter (slider, colour field, …) and press the I-Key.
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Current FrameAnimation lenght

http://pixelsix.net/
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